• If your have CLUB EVENTS/RIDE & would like to announce it here,
    Message traxxas-modifier about it :-)

Yamaha T150, Sniper 150mxi, Y15zr Mods

safrizan rahman

New Member
Good day brothers and sisters

Just need some advice on my current mods.
1. Cms 62mm racing block.
2. Cms T2 cam.
3. Cms racing spring valve.
4. Tuneboss ECU.
5. Ahm M3 spr Exhaust.

Issue is now, i can start my bike normally. But sometimes when i twist my throttle the engine dies (stall). May i know whats wrong with it? Is it the Valve setting or Tappet setting? Please advice.

Thank You.
 

20vturbo

New Member
Try changing your injectors cc brother and upgrade the throttle body. Perhaps you need to adjust the cam.Whats the lift for the cms t2 cams?
 

safrizan rahman

New Member
Try changing your injectors cc brother and upgrade the throttle body. Perhaps you need to adjust the cam.Whats the lift for the cms t2 cams?
The seller told me that my mods does not require upgrades on Injector and Throttle Body. They say my mods are only minor. CMS T2 cam lift is 5.8mm.
 

20vturbo

New Member
Is it? Most overbore kits required injector upgrade,at least.Maybe you can try servicing the stock injectors
 
we have the same prob sir, you need to change your injectors to give your engine in higher spray fuel more than the stock injector. You need 160cc flow injectors 10 holes, our stock is probably 6 holes and 148cc flow. So you can run very lean that's can give your bike poor A/F mixture... and idle poor quality.. So i suggest to replace your throttle body to 34mm size to retain your idle quality and ask to your tech about mapping adjustments RPM, fuel flow on your Tuneboss ECU.
 

mxking035

Veteran
Good day brothers and sisters

Just need some advice on my current mods.
1. Cms 62mm racing block.
2. Cms T2 cam.
3. Cms racing spring valve.
4. Tuneboss ECU.
5. Ahm M3 spr Exhaust.

Issue is now, i can start my bike normally. But sometimes when i twist my throttle the engine dies (stall). May i know whats wrong with it? Is it the Valve setting or Tappet setting? Please advice.

Thank You.
what map are you using? try adjust your clutch or change sparkplug or remove air filter
maybe its not the fuel
 

lypoc

New Member
safrizan what u need to do is just tuneup back ur afr or go to dyno for setup back due ur new spec..
 
Top